1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Noise Problem

Discussion in 'Effects [BG]' started by TaySte_2000, Jan 8, 2008.


  1. TaySte_2000

    TaySte_2000

    Jun 23, 2001
    Cheshire, UK
    I have an odd hum problem in my noise and jamming setup when I have all the pedals turned off I get like a 60 cycle hum, when I turn a pedal on it stops this is every pedal except those in a blendable loop but the hum stops when the loop is engaged so it isn't specific to any pedal on the board.

    Ideas help etc
     
  2. EHX Hum Debugger, you could always use another pedal ;)
     
  3. speak_onion

    speak_onion

    Jun 22, 2007
    Queens, NY
    What is powering that setup? If it's a daisy chain, then disconnect the pedals from the power and add them back one by one.
     
  4. bongomania

    bongomania Supporting Member Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    Ground loop. They're tricky bastards to hunt down, but hunting them down is the only real solution.
     
  5. I would definitely encourage you to fix the cause rather than throw a (hum-debugging) blanket over it to cover it up!

    If possible, power everything on batteries and see if it still does the same thing.
     
  6. irvinz

    irvinz

    Nov 23, 2006
    Australia
    has too much gas
    erm... a good excuse to leave pedals on?
     
  7. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 7, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.