Preamp issue in Xotic ProVintage Bass

Discussion in 'Pickups & Electronics [BG]' started by gimmeagig, Oct 8, 2021.


  1. I just discovered something in my ProVintage J bass.I always thought the bass( Maple and Ash) was kind of dark sounding or that type of instrument. I changed the pickups for Aguilar Humcancelling pickups and a A type Hipshot brass bridge to fix that. It got a little better but compared to my other J basses( Moon, Atelier Z and Modulus) it was still super dark.Nice tone but it lacked the sparkle on top. I was thinking about cutting my losses and selling it.
    I had the Bass and mids set to the center click position and the treble boosted to about 3/4. Yesterday, for the first time, I dialed back the bass and the mid controls a whole lot, almost completely off, about 1/8th of a turn from zero. All of the sudden I have the clarity that I was missing.And in spite of this "crazy setting" there is still plenty of bottom end fullness and punch. So now I'm wondering if the preamp on that bass is really flat when set to center click. It sure doesn't seem so. It acts like it is a boost only EQ. My question is: have you guys noticed that on your Xotic basses? Is it possible that my preamp might be defective? As it is I can totally live with it now that I know how to set it. Can't wait to take it to my next rehearsal.
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 16, 2022

Share This Page