1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Quick SVT3 technical question..

Discussion in 'Amps and Cabs [BG]' started by Venom of God, Mar 6, 2013.


  1. Venom of God

    Venom of God

    Oct 8, 2007
    Australia
    Anyone know how many amps these draw under load? Less or more than 10? This is a question from an electrician as mine is doing really funny things to the power in my house (and yes, this is all related to my SVT3 problems thread from a month or so ago!)..
     
  2. JimmyM

    JimmyM

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps, EMG Pickups
    Don't know if it's an indicator but the fuse is a 5 amp in countries with 220-240v. So it would have to be less than 5, no? Bear with me if I'm wrong here...I could be misunderstanding. But nobody answered your question yet, so at least this'll bump it ;)
     
  3. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    Less than 10......

    Actually it is not a fixed amount..... depends on the output power level. Not enough to mess with the power in your house, in general.

    The power is drawn in "spikes" of current, one every half cycle, for you at a 100Hz rate due to your 50 Hz. The current spikes will be considerably higher than the average current draw.

    What sort of "funny things" is it "doing"....?
     
  4. Venom of God

    Venom of God

    Oct 8, 2007
    Australia
    If the TV/laptop/lights are on in the other room and I'm playing I get massive volume/gain swells and the power-point the TV is plugged into makes audible popping noises (according to my girlfriend), but if it's just me home and nothing else apart from my PC is on half the time I get no swells at all and everything is fine (I assume there is no popping) and the other half it will continue to do it. It is most noticeable with a fuzz pedal because the gain is reduced so much the signal goes clean. Still does it without any effects plugged in though, and interestingly touching my pedal board causes the amp to make hissing/grounding type noises even when it's NOT in my signal chain.
     
  5. Venom of God

    Venom of God

    Oct 8, 2007
    Australia
    I should also point out that my house is a rental and was built in the late 1800's, though it has been renovated and is fairly modern inside (says nothing about when it was wired up, mind you).
     
  6. Sounds like a fire hazard.
     
  7. JimmyM

    JimmyM

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps, EMG Pickups
    I don't know...I'd be looking at the previously done wiring job rather than the amp.
     
  8. Sound to me like a symptom of poor wiring not amp performance. Floating ground coupled with a poor L1, L2 or neutral leg connection.
     
  9. Venom of God

    Venom of God

    Oct 8, 2007
    Australia
    That's what I was worried about. I'll bring it up with the real estate agent but not holding my breath considering they haven't fixed the back fence they've been promising to fix for months..
     
  10. 240v getting loose is no joke.
     

Share This Page